Debian10安装wireguard时报错
标签搜索
侧边栏壁纸
  • 累计撰写 6 篇文章
  • 累计收到 4 条评论

Debian10安装wireguard时报错

YTC233
2022-06-22 / 0 评论 / 4 阅读 / 正在检测是否收录...

前几天我在buyvm的debian10镜像的机子上配置wireguard,然后安装dkms的时候发现了这个提示
Module build for kernel 4.19.0-18-amd64 was skipped since the kernel headers for this kernel does not seem to be installed.
因为眼瞎没仔细看他英文提示的啥(since漏了导致我以为是对该版本内核不安装的意思)去网上搜了半天没搜出来咋回事
然后因为我是在配置dn42连接的时候发现的问题,所以就跑非官方群问了下,得到了大佬的解答:

l4p6ng1t.png
(好的我是伞兵)

解决方法很简单,安装当前linux内核版本相对应的linux-header就好,自动命令如下:

CentOS系

sudo yum -y install kernel-headers  //安装kernel-headers

sudo yum -y install kernel-devel    //安装kernel-devel

Debian系(包括Ubuntu)

sudo apt-get install build-essential  //install build-essential(optional)

sudo apt-get update                  //install linux-headers
sudo apt-get install linux-headers-$(uname -r)

sudo apt-get update && sudo apt-get install build-essential linux-headers-$(uname -r)
0

评论 (0)

取消